const regex = new RegExp('([abAB])\\.([abAB])', 'g')
const str = `a.b
a.B
A.b
A.B
1.2`;
const subst = `\1. \2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);