import Foundation
let pattern = #"([abAB])\.([abAB])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
a.b
a.B
A.b
A.B
1.2
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1. \2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)