using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([abAB])\.([abAB])";
string substitution = @"\1. \2";
string input = @"a.b
a.B
A.b
A.B
1.2";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}