import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([abAB])\\.([abAB])";
final String string = "a.b\n"
+ "a.B\n"
+ "A.b\n"
+ "A.B\n"
+ "1.2";
final String subst = "\\1. \\2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}