re = /([abAB])\.([abAB])/
str = 'a.b
a.B
A.b
A.B
1.2'
subst = '\\1. \\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result