import re
regex = re.compile(r"([abAB])\.([abAB])")
test_str = ("a.b\n"
"a.B\n"
"A.b\n"
"A.B\n"
"1.2")
subst = "\\1. \\2"
result = regex.sub(subst, test_str)
if result:
print(result)