use strict;
my $str = 'a.b
a.B
A.b
A.B
1.2';
my $regex = qr/([abAB])\.([abAB])/p;
my $subst = '\\1. \\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";