$re = '/([abAB])\.([abAB])/';
$str = 'a.b
a.B
A.b
A.B
1.2';
$subst = "\1. \2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;