#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^[a-zA-Z0-9_\/]+\.java):([0-9]+): ([a-z]+): ([^\n]+)\n[^\n]+([^\^]+)"
Local $sString = "Test.java:8: error: illegal start of type" & @CRLF & _
" void bla( { }" & @CRLF & _
" ^" & @CRLF & _
"Test.java:8: error: ')' expected" & @CRLF & _
" void bla( { }" & @CRLF & _
" ^" & @CRLF & _
"Test.java:8: error: ';' expected" & @CRLF & _
" void bla( { }" & @CRLF & _
" ^" & @CRLF & _
"Test.java:9: error: reached end of file while parsing" & @CRLF & _
"}" & @CRLF & _
" ^" & @CRLF & _
"4 errors"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")