use strict;
my $str = 'Test.java:8: error: illegal start of type
void bla( { }
^
Test.java:8: error: \')\' expected
void bla( { }
^
Test.java:8: error: \';\' expected
void bla( { }
^
Test.java:9: error: reached end of file while parsing
}
^
4 errors';
my $regex = qr/(^[a-zA-Z0-9_\/]+\.java):([0-9]+): ([a-z]+): ([^\n]+)\n[^\n]+([^\^]+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}