// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^[a-zA-Z0-9_\/]+\.java):([0-9]+): ([a-z]+): ([^\n]+)\n[^\n]+([^\^]+)").unwrap();
let string = "Test.java:8: error: illegal start of type
void bla( { }
^
Test.java:8: error: ')' expected
void bla( { }
^
Test.java:8: error: ';' expected
void bla( { }
^
Test.java:9: error: reached end of file while parsing
}
^
4 errors";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}