const regex = /(^[a-zA-Z0-9_\/]+\.java):([0-9]+): ([a-z]+): ([^\n]+)\n[^\n]+([^\^]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^[a-zA-Z0-9_\\\/]+\\.java):([0-9]+): ([a-z]+): ([^\\n]+)\\n[^\\n]+([^\\^]+)', 'gm')
const str = `Test.java:8: error: illegal start of type
void bla( { }
^
Test.java:8: error: ')' expected
void bla( { }
^
Test.java:8: error: ';' expected
void bla( { }
^
Test.java:9: error: reached end of file while parsing
}
^
4 errors`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}