# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(^[a-zA-Z0-9_\/]+\.java):([0-9]+): ([a-z]+): ([^\n]+)\n[^\n]+([^\^]+)"
test_str = ("Test.java:8: error: illegal start of type\n"
" void bla( { }\n"
" ^\n"
"Test.java:8: error: ')' expected\n"
" void bla( { }\n"
" ^\n"
"Test.java:8: error: ';' expected\n"
" void bla( { }\n"
" ^\n"
"Test.java:9: error: reached end of file while parsing\n"
"}\n"
" ^\n"
"4 errors")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.