re = /(^[a-zA-Z0-9_\/]+\.java):([0-9]+): ([a-z]+): ([^\n]+)\n[^\n]+([^\^]+)/m
str = 'Test.java:8: error: illegal start of type
void bla( { }
^
Test.java:8: error: \')\' expected
void bla( { }
^
Test.java:8: error: \';\' expected
void bla( { }
^
Test.java:9: error: reached end of file while parsing
}
^
4 errors'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end