import Foundation
let pattern = #"(^[a-zA-Z0-9_\/]+\.java):([0-9]+): ([a-z]+): ([^\n]+)\n[^\n]+([^\^]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Test.java:8: error: illegal start of type
void bla( { }
^
Test.java:8: error: ')' expected
void bla( { }
^
Test.java:8: error: ';' expected
void bla( { }
^
Test.java:9: error: reached end of file while parsing
}
^
4 errors
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)