import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^[a-zA-Z0-9_\\/]+\\.java):([0-9]+): ([a-z]+): ([^\\n]+)\\n[^\\n]+([^\\^]+)";
final String string = "Test.java:8: error: illegal start of type\n"
+ " void bla( { }\n"
+ " ^\n"
+ "Test.java:8: error: ')' expected\n"
+ " void bla( { }\n"
+ " ^\n"
+ "Test.java:8: error: ';' expected\n"
+ " void bla( { }\n"
+ " ^\n"
+ "Test.java:9: error: reached end of file while parsing\n"
+ "}\n"
+ " ^\n"
+ "4 errors";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}