package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^[a-zA-Z0-9_\/]+\.java):([0-9]+): ([a-z]+): ([^\n]+)\n[^\n]+([^\^]+)`)
var str = `Test.java:8: error: illegal start of type
void bla( { }
^
Test.java:8: error: ')' expected
void bla( { }
^
Test.java:8: error: ';' expected
void bla( { }
^
Test.java:9: error: reached end of file while parsing
}
^
4 errors`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}