using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^[a-zA-Z0-9_\/]+\.java):([0-9]+): ([a-z]+): ([^\n]+)\n[^\n]+([^\^]+)";
string input = @"Test.java:8: error: illegal start of type
void bla( { }
^
Test.java:8: error: ')' expected
void bla( { }
^
Test.java:8: error: ';' expected
void bla( { }
^
Test.java:9: error: reached end of file while parsing
}
^
4 errors";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}