#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?u)([\w\h,]+)\s([\w\h,]+)"
Local $sString = "Janaz" & @CRLF & _
"Одно сердцебиение" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Yug" & @CRLF & _
"Samurai" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"KseroN" & @CRLF & _
"Ты хочешь" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Seewoow, Onlife" & @CRLF & _
"Видел свет"
Local $sSubst = "$1 - $2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)