const regex = new RegExp('([\\w\\h,]+)\\s([\\w\\h,]+)', 'gu')
const str = `Janaz
Одно сердцебиение
Yug
Samurai
KseroN
Ты хочешь
Seewoow, Onlife
Видел свет`;
const subst = `$1 - $2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);