package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([\w\h,]+)\s([\w\h,]+)`)
var str = `Janaz
Одно сердцебиение
Yug
Samurai
KseroN
Ты хочешь
Seewoow, Onlife
Видел свет`
var substitution = "$1 - $2"
fmt.Println(re.ReplaceAllString(str, substitution))
}