use strict;
my $str = 'Janaz
Одно сердцебиение
Yug
Samurai
KseroN
Ты хочешь
Seewoow, Onlife
Видел свет';
my $regex = qr~([\w\h,]+)\s([\w\h,]+)~up;
my $subst = '$1 - $2';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";