$re = '~([\w\h,]+)\s([\w\h,]+)~u';
$str = 'Janaz
Одно сердцебиение
Yug
Samurai
KseroN
Ты хочешь
Seewoow, Onlife
Видел свет';
$subst = "$1 - $2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;