using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\w\h,]+)\s([\w\h,]+)";
string substitution = @"$1 - $2";
string input = @"Janaz
Одно сердцебиение
Yug
Samurai
KseroN
Ты хочешь
Seewoow, Onlife
Видел свет";
RegexOptions options = RegexOptions.CultureInvariant;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}