import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\w\\h,]+)\\s([\\w\\h,]+)";
final String string = "Janaz\n"
+ "Одно сердцебиение\n\n\n"
+ "Yug\n"
+ "Samurai\n\n\n"
+ "KseroN\n"
+ "Ты хочешь\n\n\n"
+ "Seewoow, Onlife\n"
+ "Видел свет";
final String subst = "$1 - $2";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}