re = /([\w\h,]+)\s([\w\h,]+)/
str = 'Janaz
Одно сердцебиение
Yug
Samurai
KseroN
Ты хочешь
Seewoow, Onlife
Видел свет'
subst = '$1 - $2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result