# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([\w\h,]+)\s([\w\h,]+)"
test_str = ("Janaz\n"
"Одно сердцебиение\n\n\n"
"Yug\n"
"Samurai\n\n\n"
"KseroN\n"
"Ты хочешь\n\n\n"
"Seewoow, Onlife\n"
"Видел свет")
subst = "$1 - $2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.UNICODE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.