// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?u)([\w\h,]+)\s([\w\h,]+)").unwrap();
let string = "Janaz
Одно сердцебиение
Yug
Samurai
KseroN
Ты хочешь
Seewoow, Onlife
Видел свет";
let substitution = "$1 - $2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}