# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/,\n]$/\n]/;t' <<< "[
{
\"ITEM1\":{
\"names\":[
\"nameA\"
]
}
},
{
\"ITEM2\":{
\"names\":[
\"nameB\",
\"nameC\"
]
}
},
]"