re = /,\n]$/
str = '[
{
"ITEM1":{
"names":[
"nameA"
]
}
},
{
"ITEM2":{
"names":[
"nameB",
"nameC"
]
}
},
]'
subst = '\\n]'
result = str.sub(re, subst)
# Print the result of the substitution
puts result