import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ",\\n]$";
final String string = "[ \n"
+ " { \n"
+ " \"ITEM1\":{ \n"
+ " \"names\":[ \n"
+ " \"nameA\"\n"
+ " ]\n"
+ " }\n"
+ " },\n"
+ " { \n"
+ " \"ITEM2\":{ \n"
+ " \"names\":[ \n"
+ " \"nameB\",\n"
+ " \"nameC\"\n"
+ " ]\n"
+ " }\n"
+ " },\n"
+ "]";
final String subst = "\\n]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}