#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = ",\n]$"
Local $sString = "[ " & @CRLF & _
" { " & @CRLF & _
" "ITEM1":{ " & @CRLF & _
" "names":[ " & @CRLF & _
" "nameA"" & @CRLF & _
" ]" & @CRLF & _
" }" & @CRLF & _
" }," & @CRLF & _
" { " & @CRLF & _
" "ITEM2":{ " & @CRLF & _
" "names":[ " & @CRLF & _
" "nameB"," & @CRLF & _
" "nameC"" & @CRLF & _
" ]" & @CRLF & _
" }" & @CRLF & _
" }," & @CRLF & _
"]"
Local $sSubst = "\n]"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)