import re
regex = re.compile(r",\n]$")
test_str = ("[ \n"
" { \n"
" \"ITEM1\":{ \n"
" \"names\":[ \n"
" \"nameA\"\n"
" ]\n"
" }\n"
" },\n"
" { \n"
" \"ITEM2\":{ \n"
" \"names\":[ \n"
" \"nameB\",\n"
" \"nameC\"\n"
" ]\n"
" }\n"
" },\n"
"]")
subst = "\\n]"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)