const regex = /,\n]$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(',\\n]$', '')
const str = `[
{
"ITEM1":{
"names":[
"nameA"
]
}
},
{
"ITEM2":{
"names":[
"nameB",
"nameC"
]
}
},
]`;
const subst = `\n]`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);