use strict;
my $str = '[
{
"ITEM1":{
"names":[
"nameA"
]
}
},
{
"ITEM2":{
"names":[
"nameB",
"nameC"
]
}
},
]';
my $regex = qr/,\n]$/p;
my $subst = '\\n]';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";