$re = '/,\n]$/';
$str = '[
{
"ITEM1":{
"names":[
"nameA"
]
}
},
{
"ITEM2":{
"names":[
"nameB",
"nameC"
]
}
},
]';
$subst = "\n]";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;