# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d+)(\.\d+)/$1<span class="foo">$2<\/span>/g;t' <<< "10.0/5.5/41.1"