package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d+)(\.\d+)`)
var str = `10.0/5.5/41.1`
var substitution = "$1<span class="foo">$2</span>"
fmt.Println(re.ReplaceAllString(str, substitution))
}