re = /(\d+)(\.\d+)/
str = '10.0/5.5/41.1'
subst = '$1<span class="foo">$2</span>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result