$re = '/(\d+)(\.\d+)/';
$str = '10.0/5.5/41.1';
$subst = "$1<span class=\"foo\">$2</span>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;