using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+)(\.\d+)";
string substitution = @"$1<span class=""foo"">$2</span>";
string input = @"10.0/5.5/41.1";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}