// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\d+)(\.\d+)").unwrap();
let string = "10.0/5.5/41.1";
let substitution = "$1<span class=\"foo\">$2</span>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}