const regex = /(\d+)(\.\d+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+)(\\.\\d+)', 'g')
const str = `10.0/5.5/41.1`;
const subst = `$1<span class="foo">$2</span>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);