import Foundation
let pattern = #"(\d+)(\.\d+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"10.0/5.5/41.1"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1<span class="foo">$2</span>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)