use strict;
my $str = '10.0/5.5/41.1';
my $regex = qr/(\d+)(\.\d+)/p;
my $subst = '$1<span class="foo">$2</span>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";