# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(.*)? - ([A-Z.])?\. ?([A-Z])?\. ([A-Za-z-']*)/\4, \2 \3 - \1/gm;t' <<< "No Way Home - A. C. Crispin"