const regex = /^(.*)? - ([A-Z.])?\. ?([A-Z])?\. ([A-Za-z-']*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*)? - ([A-Z.])?\\. ?([A-Z])?\\. ([A-Za-z-\']*)', 'gm')
const str = `No Way Home - A. C. Crispin`;
const subst = `\4, \2 \3 - \1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);