import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*)? - ([A-Z.])?\\. ?([A-Z])?\\. ([A-Za-z-']*)";
final String string = "No Way Home - A. C. Crispin";
final String subst = "\\4, \\2 \\3 - \\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}