import re
regex = re.compile(r"^(.*)? - ([A-Z.])?\. ?([A-Z])?\. ([A-Za-z-']*)", flags=re.MULTILINE)
test_str = "No Way Home - A. C. Crispin"
subst = "\\4, \\2 \\3 - \\1"
result = regex.sub(subst, test_str)
if result:
print(result)