use strict;
my $str = 'No Way Home - A. C. Crispin';
my $regex = qr/^(.*)? - ([A-Z.])?\. ?([A-Z])?\. ([A-Za-z-']*)/mp;
my $subst = '\\4, \\2 \\3 - \\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";